28 May 2016

How to fix parse error (APK modding)


I have spent a week trying to fix parse error. I decompiled the APK and i just found out that the minimum version of Android system was not given

If the apk does not work on your device running Android 4.1.1 or below and it work on other Android version, that means the game developer forgot to give the minimum version of Android system in the APK file or they make it unsupported


In this tutorial, i will show you how to fix parse error on Minecraft PE 0.14.3 and make it installable on any devices running Android 4.1.1 and below. It is very easy to fix it so let's get started

Tools that we need on computer:
Any apktool. You can try my GUI tool: APK Easy Tool

Step by step:
1. Backup your APK from your device or download the APK fron the internet. Read more about backup APK file

2. On your PC, download APK Easy Tool and Notepad++ and install them.

3. Open Apk Easy Tool, select the APK and decompile it


4. Navigate to the path where you decompile the APK. Right-click on Android manifext.xml and select "Edit with Notepad++"


5. The Notepad++ will open. Find the tag <uses-sdk... . if it does not exist, add the tag:
<uses-sdk android:minSdkVersion="integer" />

between other tags. Don't put it inside the tags. Replace "integer" with a number of API level. See the list below

Platform Version
API Level
Android 4.4W
9
8
7
6
5
4
3
2
Android 1.0
1

Note: If you still getting parse error, please add the property targetSdkVersion and maxSdkVersion

<uses-sdk android:minSdkVersion="integer"
         
android:targetSdkVersion="integer"
         
android:maxSdkVersion="integer" />

for older devices running 4.0.x - 4.4.x, use this tag

<uses-sdk android:minSdkVersion="14"
         
android:targetSdkVersion="23" />

for Marshmallow 6.0.x, use this tag

<uses-sdk android:minSdkVersion="14"
         
android:targetSdkVersion="23"
         
android:maxSdkVersion="23" />

In my example, I'll take the API level "16" as the minimum version of Android 4.1.1.


6. Save the file and Recompile + sign the APK with Apktool.

7. Copy the modded APK to your device, and install it.

Enjoy gaming

Proof of me playing Minecraft PE on Android 4.1.1

 





Proof of me playing Pokémon Go on Android 4.2.2




i CANNOT guarante that it will work for all devices!

0 comments:

Post a Comment